You are not logged in or registered. Please login or register to use the full functionality of this board...



Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Updating to PHP 5.3.8 in CentOS
10-17-2011, 10:56 AM
Post: #1
Updating to PHP 5.3.8 in CentOS
First you will need to install the EPEL and REMI Repositories. Use the following commands:

# wget http://download.fedora.redhat.com/pub/ep...noarch.rpm
# wget http://rpms.famillecollet.com/enterprise...ease-5.rpm
# rpm -Uvh remi-release-5*.rpm epel-release-5*.rpm

Next we can update PHP to the latest version and restart Apache.

# yum --enablerepo=remi update php php-*

# /etc/init.d/httpd restart

That should be all you need to do for the update. You can check your version with the following command:

# php -v

You may receive the following error when trying to perform the update:

Code:
# yum –enablerepo=remi update php php-*


Install 4 Package(s)
Upgrade 19 Package(s)

Total size: 12 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test

Transaction Check Error:
file /etc/my.cnf from install of mysql-libs-5.5.13-1.el5.remi.i386 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/charsets/Index.xml from install of mysql-libs-5.5.13-1.el5.remi.i386 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/charsets/cp1250.xml from install of mysql-libs-5.5.13-1.el5.remi.i386 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/charsets/cp1251.xml from install of mysql-libs-5.5.13-1.el5.remi.i386 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/czech/errmsg.sys from install of mysql-libs-5.5.13-1.el5.remi.i386 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/danish/errmsg.sys from install of mysql-libs-5.5.13-1.el5.remi.i386 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/dutch/errmsg.sys from install of mysql-libs-5.5.13-1.el5.remi.i386 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/english/errmsg.sys from install of mysql-libs-5.5.13-1.el5.remi.i386 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/estonian/errmsg.sys from install of mysql-libs-5.5.13-1.el5.remi.i386 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/french/errmsg.sys from install of mysql-libs-5.5.13-1.el5.remi.i386 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/german/errmsg.sys from install of mysql-libs-5.5.13-1.el5.remi.i386 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/greek/errmsg.sys from install of mysql-libs-5.5.13-1.el5.remi.i386 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/hungarian/errmsg.sys from install of mysql-libs-5.5.13-1.el5.remi.i386 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/italian/errmsg.sys from install of mysql-libs-5.5.13-1.el5.remi.i386 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/japanese/errmsg.sys from install of mysql-libs-5.5.13-1.el5.remi.i386 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/korean/errmsg.sys from install of mysql-libs-5.5.13-1.el5.remi.i386 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/norwegian-ny/errmsg.sys from install of mysql-libs-5.5.13-1.el5.remi.i386 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/norwegian/errmsg.sys from install of mysql-libs-5.5.13-1.el5.remi.i386 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/polish/errmsg.sys from install of mysql-libs-5.5.13-1.el5.remi.i386 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/portuguese/errmsg.sys from install of mysql-libs-5.5.13-1.el5.remi.i386 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/romanian/errmsg.sys from install of mysql-libs-5.5.13-1.el5.remi.i386 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/russian/errmsg.sys from install of mysql-libs-5.5.13-1.el5.remi.i386 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/serbian/errmsg.sys from install of mysql-libs-5.5.13-1.el5.remi.i386 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/slovak/errmsg.sys from install of mysql-libs-5.5.13-1.el5.remi.i386 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/spanish/errmsg.sys from install of mysql-libs-5.5.13-1.el5.remi.i386 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/swedish/errmsg.sys from install of mysql-libs-5.5.13-1.el5.remi.i386 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386
file /usr/share/mysql/ukrainian/errmsg.sys from install of mysql-libs-5.5.13-1.el5.remi.i386 conflicts with file from package mysql-5.0.77-4.el5_6.6.i386

Error Summary
————-
[root@host ~]#

All you need to do is run the following command to resolve the issue with mysql:

# yum –enablerepo=remi update

PHP should be all up-to-date now to 5.3.8 Smile
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)