You are not logged in or registered. Please login or register to use the full functionality of this board...

Post Reply 
Thread Rating:
  • 1 Votes - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
mount /dev/sdb1 already mounted or busy
10-02-2012, 12:36 PM
Post: #1
mount /dev/sdb1 already mounted or busy
If you're using CentOS or Fedora ... I've researched and found the solution to this problem another way.

MY PROBLEM: I too had the second and third hard drive in my system completely unmountable. I could use fdisk and make partitions, and I also could mke2fs the filesystems on these partitions as well... so I know they were not damaged or "in use" as the OS claimed. Yet after creating the filesystems, I always got "device /dev/hdc busy" error messages.

I tried the fuser command as mentioned above, but it always came up with no results, meaning that on one was sitting on the filesystems preventing them from being mounted.

Well, it's documented (centos mailing list describing symptoms and solution) and and on bug tracker at

THE SOLUTION: Seems as if a software raid utility got upgraded or installed (yum update caused it for me) called dmraid that took exclusive control over these drives and partitions, not allowing them to be mounted from the command line.

The fix: Both posts give options, but what worked for me was to uninstall the DMRAID package:

rpm --erase dmraid

yum remove dmraid
(this is the one I used).

After a reboot (dmraid holds control of these devices until the next reboot, even if uninstalled that session) then I was able to mount and unmount each of my partitions.

Hope this helps!!
Find all posts by this user
Quote this message in a reply
Post Reply 

Forum Jump:

User(s) browsing this thread: 1 Guest(s)